MiniTorque.com banner
1 - 3 of 3 Posts

·
Premium Member
Joined
·
633 Posts
Discussion Starter · #1 ·
My battery wasn't registered when it was installed about a year ago. I've currently (pun intended) got charging error come up which is showing as alternator.

Could it be related and if so, would registering now help at all or does it have to be done initially and when battery is fully charged?
 

·
Premium Member
Joined
·
5,787 Posts
you have nothing to lose doing it now, will need doing regardless even if it needs an alternator really, only a few options for battery size, like 40, 50, 70a under 'retrofits' (at least on my kit) so need to select the same size but many batteries supplied aren't exactly the same rating as the options available on the screen ime, so the closest has to be opted for, 70 is the typical iirc, one of mine had 70 something but still was registered as a 70

I'd also be inclined to explore available software updates if it were me,
 

·
Premium Member
Joined
·
633 Posts
Discussion Starter · #3 ·
you have nothing to lose doing it now, will need doing regardless even if it needs an alternator really, only a few options for battery size, like 40, 50, 70a under 'retrofits' (at least on my kit) so need to select the same size but many batteries supplied aren't exactly the same rating as the options available on the screen ime, so the closest has to be opted for, 70 is the typical iirc, one of mine had 70 something but still was registered as a 70

I'd also be inclined to explore available software updates if it were me,
Much obliged as always. Only got one of those handheld units that doesn't have options for selecting battery size so have performed the registration and will see what happens....
 
1 - 3 of 3 Posts
Top