MiniTorque.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All,

I'm trying to fit cruise control into my wife's R56 One.

It has the 2-spoke steering wheel so I've replaced it with the MFSW 3-spoke and the slip ring (61319253767).

I spent some time trawling through RealOEM to get the correct slip ring for the car, no Xenon, no auto wipers, has DSC and ended up with the part number above which I believe to be correct.

All parts fitted and no DSC issues to report after clearing the fault codes in INPA.

I have the latest BMW Standard Tools 2.12 installed but I get repeated errors when trying to read the SZL module as shown in following image.

R56 Error.jpg

As you can see the $249 has stuck in the VO/FA (orange underline in the image).

I have done the FAWrite to the CAS and FRM modules with success and performed an SGReset on all modules with the exception of the SZL as it gives errors.


Please can you advise on where I'm going wrong as I'd love to get the cruise control up and running.

I'm no master when it comes to NCS, I've only been on it for a few days and read all of the thread and guides I possibly could to help to no avail.

All help is truly appreciated :)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Have you fitted the clutch switch and wiring or are you in an auto?
I had a good look around the clutch pedal and the switch appears to be there already. I'll have to look a little deeper and see if I can trace the wiring. Any ideas of part number for the wiring incase I need to purchase one? Thanks
 

·
Registered
Joined
·
77 Posts
I think I did SG_CODEIREN to the modules rather than SG_RESET when I did it on mine. I didn’t have to do anything with the clutch pedal.

I followed the coding set out in the guide below. Go to page 17.
http://mierzwin.com/bmw/how-to/E82 Cruise Control Retrofit.pdf

The other issue is had was with the Daten files. The files I had was too out of date so it would not work. Once I updated the files it worked.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I think I did SG_CODEIREN to the modules rather than SG_RESET when I did it on mine. I didn’t have to do anything with the clutch pedal.

I followed the coding set out in the guide below. Go to page 17.
http://mierzwin.com/bmw/how-to/E82 Cruise Control Retrofit.pdf

The other issue is had was with the Daten files. The files I had was too out of date so it would not work. Once I updated the files it worked.
Thank you ever so much for the guide. I did perform the SG_codeiren at the time but I think I will retry it and also include $540 as so far I've just done $249.

I agree that I too could have a daten file issue. What is the best way to check that I have the latest datens?
 

·
Registered
Joined
·
2 Posts
I have 07 MCS that came without MFSW, I have replaced SZL and added buttons to the steering wheel. Radio controls worked right away so then I added $249 to the CAS and FRM and did SG_RESET on every module and cruise control still doesn't work, when I press cuise control buttons nothing happens.

Help
 

·
Registered
Joined
·
2 Posts
Ok I got cruise control working, for anyone that is still trying to do this in 2019 if you have done SG_RESET on every module and it hasn't worked, do SG_CODIEREN. This worked on my MCS
 

·
Registered
Joined
·
46 Posts
I have 07 MCS that came without MFSW, I have replaced SZL and added buttons to the steering wheel. Radio controls worked right away so then I added $249 to the CAS and FRM and did SG_RESET on every module and cruise control still doesn't work, when I press cuise control buttons nothing happens.

Help
did you just add the steering wheel or did you need the slip ring as well? (what build date is your car)... I've got an )7 MCS (May Build) and going to do the retrofit shortly.. just acquiring the parts just now... :)
 

·
Go Go Gadget Mini
Joined
·
1,613 Posts
Finally got it all working on mine. I didnt have to process the car. Just enable the functions via NCS and with the correct SZL it all worked fine.

I bought one SZL 61319253763 which didnt work for my car as I have xenon and this didnt like them.

Then i bought SZL with number: 61313453991 and as soon as it was swapped over everything came to life and worked perfectly.
 

·
Registered
Joined
·
46 Posts
Finally got it all working on mine. I didnt have to process the car. Just enable the functions via NCS and with the correct SZL it all worked fine.

I bought one SZL 61319253763 which didnt work for my car as I have xenon and this didnt like them.

Then i bought SZL with number: 61313453991 and as soon as it was swapped over everything came to life and worked perfectly.
lol!! - you don't hang about!! - GOOD JOB! :)

i've still not got round to it!! (no time!!)

do you have xenons and DSC?
 
1 - 11 of 11 Posts
Top