MiniTorque.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter #1
Hi guys,

Had my first Mini problem the other day. Coming back from Stratford last Sunday the car started idling at 1200ish RPM and hunting.

Last night had a look for an air leak and found one of the boots that connects to the intercooler had been squashed and wasn't fitted properly. Sorted that out and now no air leak, result! Except now the car won't idle. Removed the throttle body and cleaned it but no change. Disconnected the battery and still no change.

Taking a closer look the TB is actually snapping shut when the engine is running. It will still drive if you keep the revs up but as soon as they drop the TB shuts and the car stalls.

No codes on Scangauge.

Any ideas what's causing this? Has the car running with the air leak caused something to trip somewhere? Is this the sign of another problem?

Cheers.
 

·
Registered
Joined
·
347 Posts
Discussion Starter #3
It is, if it's disconnected it will idle but sounds rough.

Got the correct software connected up, cleared the adaptives(?) and it's working fine now.
 

·
Registered
Joined
·
2 Posts
It is, if it's disconnected it will idle but sounds rough.

Got the correct software connected up, cleared the adaptives(?) and it's working fine now.
Hi mate I know this is an old post but I am getting these exact symptoms on my.mini what do you mean by adaptives
 

·
Premium Member
Joined
·
4,949 Posts
adaption reset
 

·
Registered
Joined
·
40 Posts
I think you can clear them by removing the battery for a few minutes? It's to make sure the ECU has forgotten it adaptive values, as it will have learned how to try and compensate for the air leak the OP had.

If the car won't idle when cold though that won't help - mine had that issue, and it was the MAP sensor just above the radiator which was not reading properly.
 

·
Registered
Joined
·
2 Posts
I think you can clear them by removing the battery for a few minutes? It's to make sure the ECU has forgotten it adaptive values, as it will have learned how to try and compensate for the air leak the OP had.

If the car won't idle when cold though that won't help - mine had that issue, and it was the MAP sensor just above the radiator which was not reading properly.
Changed my Map sensor and idles fine now
 
1 - 7 of 7 Posts
Top