MiniTorque.com banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all. I’ve got a 2004 Cooper S, it runs great, no problems at all.
When I turn the ignition on to the 2nd position my warning lights come on, except for the oil pressure warning light. It never comes on at all, neither yellow or red.
I ran the dashboard test and when I do that the oil pressure light comes on red and then yellow so I know the indicator is working.
Anyone got any ideas why the oil pressure/level indicator wouldn’t be working?
Thanks
 

·
Premium Member
2005 R53, 2005 R53 lightweight, 2008 R55S, 2012 R58FJCW, 2014 R60SD All4, 1996 Mini Cooper 35SE.
Joined
·
6,439 Posts
yes, certain individuals might disconnect them to sell a car.

not aware of the oil light having a yellow function?

fyi there isn't a level sensor on a gen 1.
 

·
Registered
Joined
·
46 Posts
Any update on this? I've just noticed my R53 has never lit up the oil pressure light with the ignition on, and I've owned it for 4 years and done over 40k on it 😂 Light comes on during the test as well so it isn't the LED.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
No definite solution yet as I haven’t had chance to change the sensor.
What I have noticed is that the oil light occasionally comes on if the car has been run, is then turned off and then back on again to ignition position 2 (without starting the engine). The Oil light comes on briefly and one time stayed on for a good 10 seconds while the ignition was in position 2. As soon as i started the car it went back off, as expected.
I think it’s just a dodgy sensor in my case. The garage I use locally said there was no sign of oil pressure problems and I’m taking it back there to have the sensor looked at hopefully this week or next.
 

·
Registered
Joined
·
46 Posts
For all I know the plug on the sensor on mine might not even be connected, now that I know it's an issue I'm not going to be happy until I've fixed it. Ahh blissful ignorance eh?

Given how cheap the sensors are, I think I'll just buy a replacement and throw it in and see if that fixes it. I'll report back when I've done it.
 
1 - 12 of 12 Posts
Top