MiniTorque.com banner

1 - 9 of 9 Posts

Registered
Joined
4 Posts
Discussion Starter #1
Hi all, Iv'e bought a problem child, 2008 Cooper S, but I love it! I've been looking at the forum for the last 2 weeks and have found some really useful information so, decided to join a forum for the first time!
As some background on the car, I bought it knowing it had issues, it has basically been unloved and poorly maintained. The car was low on power, poor fuel consumption, lumpy on tickover and awful to drive. I decided to start with the basics, new fuel filter, plugs, airfilter, all the service items. I also checked the inlet valves which were sooted up so I cleaned them. I also replace the coil sticks. The transformation was remarkable, but still not right. Still low power and repeated code, rich on bank 1, LAMBDA reading on my reader off the charts, I thought maybe a sensor.
At the weekend, I had to fit new bolts to the OSF driveshaft mount as they went missing, leaving me stranded on the M54! Anyhow, to give me a bit more light I removed the air filter box, and whilst there decided to remove the awful noise generator, using a juice bottle lid and araldite to seal the pipe! Completed the work, topped up gearbox and took her for a spin and it runs perfectly! Don't know if this is luck and I've just knocked a connector, or whether the sound generator was causing at least part of the problem, thought this may help someone.
Now I have her/it running, I hope to upgrade bits and as they fail and money allows and hopefully I can make a contribution to the forum.
 

Registered
Joined
126 Posts
If the sound generator is in the induction system and has a leak (usually a split diaphragm) it will affect the car's running as it causes metered air to exit or entre the engine.
 

Registered
Joined
109 Posts
Welcome to MT, great bunch of guys on here with lots of info.


Sent from my iPhone using Tapatalk
 

Registered
Joined
8 Posts
Welcome from me another newbie. Glad to hear you've sorted some of your minor running issues, despite getting stranded on the M54 :(
 

Registered
Joined
4 Posts
Discussion Starter #9
Thanks for the welcome! Unfortunately it would appear I've not yet got to the bottom of my cars issues, current train of thought is that maybe the valve timing is out. Going to check it today and will hopefully post something in the appropriate area. I will get there in the end!
 
1 - 9 of 9 Posts
Top