MiniTorque.com banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
4 Posts
Discussion Starter #1
Hi guys and gals

Just got myself a r53 s 2004 with a hundred k. The clutch was knackered so I decided to remove the engine
Replace the clutch service supercharger with fresh oil, fitted a new water pump to be on the safe side and also did a 15% pulley kit. The car has had new brakes and I’ve had the wheels shot blasted and painted in dark grey with disco light lacour (sorry spelling ain’t my best point/ neither is my grammar).
I’ve stuck 4 new tyres on as well. The car already had a k and n fitted inside the air Box and a stainless custom exhaust. My names andy any comments will be greatfullly received.
Don’t know how to post pictures from my iPhone if anyone can help
Thanks
 

·
Premium Member
Joined
·
3,996 Posts
15% sensible choice

now get a cam ;O)

even a mild cam will make better use of the air you're sending in and free up the entire rpm scale, I can supply any Newman @ £250 or fit for only £312 plus bolt/s and seal/s, while you wait no problem usually, you don't need to map the car for a mild cam but more so for any pulley, or fast road cam in conjunction with one particularly really, bearing in mind even the JCW with an 11% pulley was mapped for it, it figures any other size would require it to protect your engine and get the best from all parts.
 

·
Premium Member
Joined
·
4 Posts
Discussion Starter #8
Thanks so much for all the reply’s I’ve added 2 pictures at the moment. Thanks everybody
 

·
Premium Member
Joined
·
4 Posts
Discussion Starter #12
wonder if u guys can help me!!
ive got an air bag light! its saying battery terminals which was dirty!cable dry
found the 3rd break light seal to be at fault. all connections cleaned seal fixed reset light and now its saying passanger seat..... but if i clear again it says battery terminal.....
any ideas please people.
im new here and still aint found the best way to add my car pics here if any 1 can help me. thanks andy
 
1 - 13 of 13 Posts
Top