MiniTorque.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello people i need some help im new to here and im hoping someone has had the same problem any advice would be a big help.

i recently replaced control arm bushes, balljoints, droplinks and struts, strutmounts and coilsprings

i changed to FK shocks with eibach lowering springs and since the install ive got a horrible popping noise from the front when turning mainly at low speed.

its definitely not the strut mount or cv joint or wheel bearing etc. it is definitely coming from the strut.

the struts are assembled correctly and as far as i can tell ive not done anything wrong. im not sure but could it be possible that ive over tightened the top nut or that the spring ends need greasing or something like that. ive pulled it apart 3 times already and its sending me nuts.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!PLEASE HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

Attachments

·
Administrator
Joined
·
5,546 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #3
i know that the FK Coilovers well the cheaper ones are a pile of steaming shit but these are struts they aren't coilovers
and i think for what they are they are decent enough quality. im not sure of the model number and i got a good price on them
but i just need to find out where ive fucked up because the struts aint to blame
 

·
Premium Member
Joined
·
5,039 Posts
It sounds like the spring shifting on its seat when the steering is turned if only doing 'as' you turn the steering, but if while you're rolling slowly and on lock, my guess is the wheel alignment is out, and the tyre is jumping on lock. Some makes of car do this anyway, the Mercedes in particular on some models. If you have lowered it and also had it apart doing stuff, get it checked, you'll find either toe out or/and neg camber contribute, most likely nothing to do with parts choices, just modification consequences.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
top mounts aren't seized they are brand new.

and to CarsorBikes

thanks for your response i think you may be onto something. from looking at the wheels from the front id say there is definitely noticeable negative camber and it makes the noise when either pulling away, stationary or normal driving except when driving at road speeds its a single bong when turning either direction.

it is a bit of a tricky one because ive been working on cars for years and am on my second one of these minis and done all the work on the last one myself with no dramas

it definitely needs the alignment doing im just trying to make double sure i get this bloody noise sorted to avoid getting the tracking done multiple times.

i did pull it apart again this evening checked everything and still no obvious sign.

only other thing i can think of is when i pulled the old struts apart it had a washer and a grease cap that go's under the strut mount on the new strut mount its a sealded bearing so grease cap was chucked but in a few places ive read about 2 washers but im not sure about this?
 

·
Registered
Joined
·
229 Posts
id go for the springs siezing and pinging free, are there any inserts in the shocks and do they turn freely on the top mounts?
 
1 - 11 of 11 Posts
Top