MiniTorque.com banner

1 - 3 of 3 Posts

Registered
2007 Mini Cooper S R56
Joined
6 Posts
Discussion Starter #1
Hi all, first post for me and I need you help?

I have recently bought a 2007 Cooper S with a blown engine. I have completely rebuilt the engine and have had it running in the car for the last 2 weeks. Keeping revs down and have not laboured the engine too much. The amber engine light was on when I put the engine in and stayed on but turned it self off after 4-5 days of driving. However if I push the engine and introduce a little boost, the engine light soon comes back on again. If I then drive carefully for 10 mins it again goes out.

The car was remapped by the previous owner and I have seen 18psi on the gauge. However when the engine light comes on it only gives me max boost of 11psi (standard)

I am running it in, done 280 miles since build and already into my second oil change. I have pushed it to 5000rpm twice, but the difference in performance between engine light off an on is chalk and cheese

My question is:
1. Is it coming on because it鈥檚 still being run in and the piston rings may not be 100% sealed?
2. Is hitting max boost of 18psi (engine light off) triggering the engine light and perhaps I need to change more parts to prevent this. I understand there are other parts which being standard could give me issues running max 18psi

The following mods have been done by me.
Large intercooler
K&N filter
3 inch stainless exhaust with a performance cat downpipe
New KO3 JCW turbo
Full set silicon pipes with noise delete
Previous owner said he had remap to 230bhp.

I am loving this car, done loads of bodywork, brakes and suspension mods.

Any knowledgeable people out there that can offer some advice please. If it is a case of waiting to run in then great, I suspect though every time I push the turbo it鈥檚 going to turn on the engine light馃様
 

Registered
2007 Mini Cooper S R56
Joined
6 Posts
Discussion Starter #2
Hi all

Looks as though I am getting the half power engine light come on which I see is quite common. I have noticed the engine is running really rich as the exhaust is very sooty. Wonder if this is helping to trigger the half power engine light.
I brought the car with. A remap, and don鈥檛 know where it鈥檚 from. Would a decent tuner be able to address the rich running, or is this a characteristic of the car with direct injection?

Help 馃槱
 

Registered
2007 Mini Cooper S R56
Joined
6 Posts
Discussion Starter #3 (Edited)
FIXED!!

I read on here that the fault can also be brought on if the car boosts too high. A new diverter valve was recommended with the metal internals.
Fitted a GFB diverter valve and removed the blow off valve.

Engine light no longer comes on馃槉. Not sure if it was the blow off valve or the better diverter valve.
 
1 - 3 of 3 Posts
Top