MiniTorque.com banner

21 - 29 of 29 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #21
Thanks for the replies everyone, I run premium fuel, car is stock currently so something would amiss if I need octane booster on top of that.

I have not checked that, but will do later thanks!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
77 Posts
Discussion Starter #23
Thanks for that, I’ll have a look later and see if anything is wrong


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
871 Posts
Just a thought, how long has the fuel been in the car? A lot of cars (mine included) aren't going far at the moment and haven't been filled up for months.

Sent from my HRY-LX1 using Tapatalk
 

·
Registered
Joined
·
77 Posts
Discussion Starter #25
It’s got fresh fuel in, I filled up after doing the filter and took it for a run. It’s a noise that has come and gone since I’ve had the car but I’ve not really looked into it in terms of potential fuelling issues until the thread I mentioned came up.. it’s possible it’s just a bad lifter or something simple like that. I will be getting stuck into it over the next couple of weeks and see if I can get to the bottom of it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
871 Posts
Lifter isn't a bad shout, I had issues on my last engine. Although they would often be noisy from cold at idle. Used to hear a light tapping at 2.5-4k even when they were quiet at idle though.

Sent from my HRY-LX1 using Tapatalk
 

·
Registered
Joined
·
77 Posts
Discussion Starter #27
Lifter isn't a bad shout, I had issues on my last engine. Although they would often be noisy from cold at idle. Used to hear a light tapping at 2.5-4k even when they were quiet at idle though.

Sent from my HRY-LX1 using Tapatalk
This is what I’m getting, above 50% load roughly that rpm range I get tapping. Sometimes it will continue higher up to 5.5k ish and sometimes it won’t do it at all. Car doesn’t hold back or anything it’s just a bit noisy. I just thought for the sake of a fuel filter that needed doing anyway it was worth a go lol. I’m taking front off soon anyway to do charger service, pulley and cooking system stuff so I’ll have a look at everything while I’ve got the inter cooler off.


Sent from my iPhone using Tapatalk
 

·
Registered
2006 R53 Hyper Blue/White Cooper S
Joined
·
273 Posts
Because hobo :cool: I bought a Vaico filter with the gaskets and has been fine for almost 2 years now.
This, Vaico went in mine a year ago no problems at all. I wanted to go OE but wasnt gonna spend nearly 50 quid on a piece of paper (y)

So long as you buy one from a reasonable aftermarket brand I dont think you can go too far wrong.
 

·
Registered
2006 R53 Hyper Blue/White Cooper S
Joined
·
273 Posts
This is what I’m getting, above 50% load roughly that rpm range I get tapping. Sometimes it will continue higher up to 5.5k ish and sometimes it won’t do it at all. Car doesn’t hold back or anything it’s just a bit noisy. I just thought for the sake of a fuel filter that needed doing anyway it was worth a go lol. I’m taking front off soon anyway to do charger service, pulley and cooking system stuff so I’ll have a look at everything while I’ve got the inter cooler off.


Sent from my iPhone using Tapatalk
Crank pulley can make a tapping noise on some cars, quite common I gather. My 06 does it mate.....I thought it was tappets but it's good as gold at idle or if revved a little when stationary...under load it ticks and am sure it's this. Doesnt mean its failing necessarily as I've had mine inspected and looks fine, but they can get noisy.

I find not so obvious with window closed, very obvious with it open....irritated me a bit when I first got the car and was paranoid something was up with it but a year later, still fine, same noise.

I might get mine done next time it needs a new serp belt.....genuine article isnt cheap tho (knocking on 250 notes just for the pulley I believe).
 
21 - 29 of 29 Posts
Top