MiniTorque.com banner
1 - 5 of 5 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 · (Edited)
Hi all

Recently bought a Evolve V2 IC for my 2008 FJCW, it was secondhand having spent 3000 miles on a WC50 JCW year unknown. Well last Saturday it was time to fit:thumbup: and enjoy the added performance but sadly it just wouldn't align correctly.
I came across 2 main issues:
1) The ic wouldn't sit back far enough dud to a clash condition with the modular front end assy
2) When looking at the front of the car the ic wouldn't go far enough to the left to allow the mounting screw to fit despite slots on the ic both sides. Looking underneath, the RH ic pipe won't go any further left as it is hard up against the MFE.

The ic appears to be an incredibly tight fit all round, is this correct?

So after all that work the oem is now back on:mads:

I have emailed evolve but no response yet, I will call them as it is always easier to explain directly. Has anyone else come across fitment issues or am I missing a fitment trick?:confused1:

Will upload pics asap - Once it will accept my jpg format.
 

·
Registered
Joined
·
207 Posts
When I fitted mine i couldn't get it to sit all the way back which meant the pipes wouldn't sit flush on it. I remember I got the die grinder out and trimmed some plastic brackets around the area. I think they were either for the radiator or the aircon. Anyway, with a bit of trimming, the pipes then sat on better, still not perfect, but I'm happy with them. Hope this helps
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Thanks Adam, I spoke to Evolve yesterday and this helped. Your diagnosis is exactly what I am up against, for some reason my photos won't upload but show this. I am a little disappointed that it doesn't fit like a glove, not sure if the Forge is a better fit either way they are not a cheap copy which you might expect a poor fit from:sad:
 

·
Registered
Joined
·
47 Posts
I recently had an Evolve IC fitted to my 2011 fJCW and the garage that fitted it reported no issues whatsoever with fitment. Mine was a V2 Evolve.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
Thanks Moonigan, looking at the evolve site they show a customers car that is later than mine and there are differences to the mfe which is to be expected. Talking to Paul at evolve the design size has never changed which is what I thought so it is a right pain especially when you hear of no issue installs!
 
1 - 5 of 5 Posts
Top