MiniTorque.com banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello everybody.

I am Pablo from Spain, I am a user of Minis Spanish Forum but i could find a good response for this answer.

I had a N14 cooper S but now I have just bought a N18 Jcw.

It is a very similar car but as you know with some updates issues.

I have a question related to a coolant Temps. The Cas is not remap yet but I am looking Tha the coolant Temps is no stable. It rise up to 88°C and the thermotate open ant the Temps go down to 78°C. It works all the time as I have described.

I know the N18 jcw works coolers but so cold didn't know.

In my old R56 Mcs it works all the time in a stable 107°C and opens the thermostate when I demand to the engine.. I think it is the correct way of working

Somobody with this model who can helps me.

Thanks for so good forum...

Karbi
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
That temp drop is also normal for a mapped car, or one with a changed thermostat,
are you 100% sure it's stock ?

Sorry but my jcw is a 2012 n14 so I cannot advise you exactly
Thank you fou your answer, I am sure that the car is not mapped, but I didn't know that there is a thermostat that works like that.

The car is only 47.000km the year is 2013 and all the maintenance is done in a oficial service. May be was a called from BMW to change the thermostat??
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
In the oficial service told me that the car is not passed and is not included in any campaing related of the thermostat.
After check with an another Jcw N18 it seems to be something wrong with the thermostat. The other car works all the time umin a stable 90-92°C.

I am going to change the thermostat... I will tell you my conclusions.

It's a shame not to recive more information of anothers Jcw N18. It would be very helpful.
 

·
Registered
Joined
·
98 Posts


Not sure what brand OEM use but above links most open up over 100°C .

Could be different country have different opening temps.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Sorry for my late response.

I changed my termostate and now is working perfect. The normal temperature is a constant 88-89 °C and when is needed by you driven conditions (track mode) it works at 85°C.

Thank you for you help
 
1 - 8 of 8 Posts
Top